Main window closes if i use second monitor

Discussion in 'General Discussion' started by Baalrog, Jan 29, 2018.

  1. Baalrog

    Baalrog New Member

    When i have the game running on my main monitor and click on my second monitor, the game alway minimizes. Does anybody know how to prevent that?
    Cheers Baal
     
  2. Suno

    Suno Member

    Run the game window mode.
    [​IMG]

    [​IMG]
     
  3. Baalrog

    Baalrog New Member

    I did that but my screen uses 1600x1200 which the game doesnt offer me.

    Well i will try different screen sizes tomorrow and see how thats goes.

    Thanks for the advice.
     
  4. waterProphet

    waterProphet New Member

    Full screen will close in any game you try. It's a windows thing. Eventually, hopefully Ves will put borderless fullscreen into the game, which will allow you to switch screens without minimizing. But... that's development resources. So you'll just have to cross your fingers and hope it happens one day.
     
  5. Zer0CoolAZ

    Zer0CoolAZ Administrator Staff Member

    1600x1200 as a default windowed resolution is not available, you are correct. You're using a relatively uncommon resolution. With windowed mode you won't usually find an exact resolution to match your screen. Sometimes games are able to dynamically allow resolution changes (Dragging the border of the window to make it larger) but in most cases you just need to pick a resolution that fits within the height and width confines of your desktop and isn't too small for you. Otherwise you'll have to expect that using anything on a second or third (so on) screen will result in the game losing primary active focus, thus minimizing it. (In Fullscreen mode. Most things in Fullscreen do this. Windowed Fullscreen is a bit different, but isn't offered here at the moment)
     
  6. Suno

    Suno Member

    He can try using the steam launch options to force window fullscreen maybe?
    Idk how this would work though, since setting are applied on the unity launcher and not within the game itself. Prehaps you could somehow just bypass the unity launcher and launch the game direct with ~fullscreen ~windowed? (i think thats the command)
    Can't really be assed dicking around with it though, i hope these suggestions go somewhere :p

    https://support.steampowered.com/kb_article.php?ref=1040-JWMT-2947
     
  7. Zer0CoolAZ

    Zer0CoolAZ Administrator Staff Member

    I have tested this to some degree, and as you said, Unity's launcher settings take over. In your method what happens is that Steam attempts to force the first window it opens into the defined resolution. Since it hits a launcher screen this is moot. Doing -w, -h, -fullscreen, -windowed, etc., will all basically be useless since the game does use Unity's settings.
     

Share This Page